La synchronisation verticale n’est pas d’aplomb

Résumé des épisodes précédents. Sur mon Raspberry pi, j’ai installé une raspbian en suivant le quick start du site officiel. Les premiers temps passés, j’ai procédé à l’installation de XBMC sur Raspbian (et non un raspbmc). La version 11 dite Eden fonctionnait à l’exception d’une surconsommation processeur dans les temps morts –un comble. Comme recommandé j’ai évolué vers la version 12 dite Frodo nouvellement arrivée à l’époque, mais sans la correction escomptée. Or je suis exigent, que ça fonctionne n’est pas suffisant, il faut que ça fonctionne bien !

En avant les recherches ! Une première piste que je raconte dans l’épisode XBMC in the dirty regions, offre une baisse de CPU au détriment de l’interface, cette solution peu élégante réclame l’usage exclusif de télécommande ou de smartphone disposant de l’application idoine.
En poussant encore un peu, j’ai trouvé (voir le forum officiel)ce qui semble être LA solution : Activer la synchronisation verticale.

Là où le bât blesse, c’est que cette activation ne souffre pas que je regarde des vidéos !

Lire la suite…

chart_20130417-1902-0014

Pour faire gagner du temps à certains, cet article n’apporte aucune réponse applicable, et n’est qu’un exposé d’observations.

Procédons à une lecture de ce premier graphe macro. L’usage CPU est d’environ 20% quand XBMC n’est pas utilisé. Puis la charge monte à 55% quand on le réactive, le sollicite par smartphone remote, que l’on choisit une vidéo et qu’on la lance. A la lecture, ça se stabilise à 40% d’usage CPU. Et quand la lecture s’arrête, paf ! La CPU explose à 90%.
Un second graphe plus ciblé permet de mieux dégager l’heure des événements que l’on peut mettre en relation avec l’historique disponible dans le home de l’utilisateur du service xbmc dans le ~/.xbmc/temp.

chart_20130417-2041-2144

En parcourant l’historique ci-dessous, je découvre plusieurs points :
19:32 – 3 erreurs qui sont systématiques dès que j’active la synchronisation verticale (vsync).
20:48 – 3 avertissements lors de la montée en charge
20:57 – aucune notifications lors de la stabilisation de la charge
21:40 – 1 erreur lors de l’explosion

Manches retroussés, je récolte toutes les informations nécessaires sur ces quelques lignes peu amènes.

XBMC-Log-20130417

[Edition du 03/05/2013] Depuis les quelques jours suivant cet article, je n’ai pas pris le temps de chercher. Mais force est de constater que le problème n’est pas constant. Et si je me suis servi du XMBC, le souci n’est réapparu que de la soirée du 24/04/2013 à celle du 25/04/2013 dont l’usage du XBMC a remis les choses en place.
Affaire à suivre…

chart_20130403-20130503

2 réflexions au sujet de « La synchronisation verticale n’est pas d’aplomb »

  1. Bonjour Olivier,

    Je suis avec attention tes réglages du Pi car j’ai choisi la même configuration que toi (raspbian + xbmc). Comme toi j’ai un soucis avec le CPU qui est complétement consommé lorsque xbmc est lancé.
    N’ayant pas de télécommande j’ai choisi de laisser xbmc ouvert la totalité du temps sans écran de veille, c’est à dire que je ne ferme jamais l’appli et j’éteins juste la TV au besoin. Je le contrôle comme toi avec un smartphone, cela évite d’acheter du matos supplémentaire et de squatter les ports USB déjà peu nombreux.

    Ma question est la suivante : Dans « L’usage CPU est d’environ 20% quand XBMC n’est pas utilisé » qu’entends tu par « XBMC n’est pas utilisé » ? Y’a til un mode « eco » à activer ou autre ? Car pour moi c’est toujours plus de 50% de cpu…

    Pour le reste je suis en attente de ta solution si tu trouve ! Merci encore !

    • Mon installation similaire à la vôtre, et je n’arrête jamais l’application XBMC. Par « XBMC n’est pas utilisé », je veux dire que je ne regarde pas de vidéo, ni n’écoute de musique. Et dans ce cas, la consommation cpu est de 20%.

      J’ai sans doute réussi à saisir dans la journée du 24/04/2013, un des rares ratés, puisqu’encore aujourd’hui, je n’ai plus observé de telle surconsommation.
      A noter que depuis l’artile, j’ai procédé à beaucoup de mises à jour en tout genre.
      Lorsque j’ai installé mon Raspberry, il était déjà en version Debian 7.0 dite wheezy, soit 3 mois avant la sortie définitive et officielle début mai 2013. Hypothèse de ma part (totalement invérifiée) : Depuis avec la version officielle, j’ai pu mettre à jour des packages qui comportaient une instabilité ou qui n’étaient pas totalement aboutis.

      Tout ce que je peux ajouter est que l’option de synchronisation verticale doit être validée 2 ou 3 fois avant d’être gardée définitivement ; ça ne parait pas cohérent mais c’est la seule observation que j’ai pu effectuée.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *